安全与隐私开源项目

密码、身份与安全工具。本类收录 116 个项目;从具体用途和部署条件开始筛选,再阅读项目原始资料。

发现值得使用的开源项目

找到 116 个项目

安全与隐私 7万

Vaultwarden

dani-garcia/vaultwarden

使用 Rust 实现的轻量 Bitwarden 服务端 API,适合比较自部署密码管理方案。

RustDocker资料更新 2026-10-29
查看项目详情
安全与隐私 2.1万

Bitwarden

bitwarden/server

Password manager with a webapp, browser extension, and mobile app.

DockerC#资料更新 2026-10-30
查看项目详情
安全与隐私 6197

Passbolt

passbolt/passbolt_api

Collaborative password manager.

PHPdeb资料更新 2026-10-20
查看项目详情
安全与隐私 3355

AliasVault

aliasvault/aliasvault

End-to-end encrypted password manager with a built-in email alias generator and server.

Docker资料更新 2026-10-31
查看项目详情
安全与隐私 1873

Teampass

nilsteampassnet/TeamPass

Password manager dedicated for managing passwords in a collaborative way. One symmetric key is used to encrypt all shared/team passwords and stored server side in a file and the database. works on any server Apache, MySQL and PHP.

PHP资料更新 2026-10-26
查看项目详情
安全与隐私 未提供

authboss

volatiletech/authboss

Modular authentication system for the web. It tries to remove as much boilerplate and "hard things" as possible so that each time you start a new web project in Go, you can plug it in, configure it, and start building your app without having to build an authentication system each time.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

authgate

go-authgate/authgate

A lightweight OAuth 2.0 Authorization Server supporting Device Authorization Grant (RFC 8628), Authorization Code Flow with PKCE (RFC 6749 + RFC 7636), and Client Credentials Grant for machine-to-machine authentication.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

branca

essentialkaos/branca

branca token specification implementation for Golang 1.15+.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

casbin

hsluoyz/casbin

Authorization library that supports access control models like ACL, RBAC, and ABAC.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

cookiestxt

mengzhuo/cookiestxt

provides a parser of cookies.txt file format.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

go-githubauth

jferrl/go-githubauth

Utilities for GitHub authentication: generate and use GitHub application and installation tokens.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

go-guardian

shaj13/go-guardian

Go-Guardian is a golang library that provides a simple, clean, and idiomatic way to create powerful modern API and web authentication that supports LDAP, Basic, Bearer token, and Certificate based authentication.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

go-iam

melvinodsa/go-iam

Developer-first Identity and Access Management system with a simple UI.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

go-jose

go-jose/go-jose

Fairly complete implementation of the JOSE working group's JSON Web Token, JSON Web Signatures, and JSON Web Encryption specs.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

go-jwt

deatil/go-jwt

A JWT (JSON Web Token) library for Go.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

go-jwt

pardnchiu/go-jwt

JWT authentication package providing access tokens and refresh tokens with fingerprinting, Redis storage, and automatic refresh capabilities.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

goiabada

leodip/goiabada

An open-source authentication and authorization server supporting OAuth2 and OpenID Connect.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

gologin

dghubble/gologin

chainable handlers for login with OAuth1 and OAuth2 authentication providers.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

gorbac

mikespook/gorbac

provides a lightweight role-based access control (RBAC) implementation in Golang.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

gosession

Kwynto/gosession

This is quick session for net/http in GoLang. This package is perhaps the best implementation of the session mechanism, or at least it tries to become one.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

goth

markbates/goth

provides a simple, clean, and idiomatic way to use OAuth and OAuth2. Handles multiple providers out of the box.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

jeff

abraithwaite/jeff

Simple, flexible, secure, and idiomatic web session management with pluggable backends.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

jwt

pascaldekloe/jwt

Lightweight JSON Web Token (JWT) library.

Go维护时间未提供
查看项目详情
安全与隐私 未提供

jwt

cristalhq/jwt

Safe, simple, and fast JSON Web Tokens for Go.

Go维护时间未提供
查看项目详情

找到项目,也找到下一步。项目来源、统计时间与验证程度均可追溯。

数据与更新说明